User Tools

Site Tools


raspberry_pi_dev_environment

To start with, you will need the libserial0 and libserial-dev packages. The default raspbian distro does not include them, so I wound up compiling them from ubuntu sources.

Download the appropriate files and install them using dpkg:

$ sudo dpkg -i libserial0_0.6.0_rc1-0ubuntu4_armhf.deb

You only need the first one if you have the KingPin binary and just want to run it. You will need the second one if you intend to download the KingPin sources and want to compile them. The third one is the documentation which may be useful if things don't work.

raspberry_pi_dev_environment.txt · Last modified: 2015/03/02 17:33 by spierepf